Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Android requiere el nivel de cumplimiento del compilador 5.0 o 6.0. Se encontró '1.7' en su lugar. Utilice Herramientas de Android> Fijar propiedades del proyecto

¿Alguien tiene problema similar con esto, importación de proyecto android y obtener errores como

[2011-10-03 17:20:09 - Screen] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. [2011-10-03 17:21:55 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. [2011-10-03 17:21:59 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 

Tengo errores para borrar todas las funciones anteriores de @Override. Tengo Windows 7 x64, jvm7 x64. ¿Alguien tiene idea de lo que está mal? (He hecho herramientas de Android -> Fix Project Properties, pero didn; t ayuda)

  • ¿Puede alguien dar una buena explicación de Dagger 2?
  • Error al instalar parches de reinicio cuando se inicia la aplicación android con Android Studio 2.0
  • Guardar datos de usuario durante un día (el mismo día -> muchos datos de usuario)
  • ¿Un buen tutorial para usar AccountManager en Android?
  • Cómo implementar pestañas ahora que TabActivity está obsoleto
  • ¿Cómo salir de una aplicación de Android con código?
  • Cómo guardar / guardar objetos de clase personalizados en Android?
  • ¿Cómo volver a ejecutar la prueba fallada en Espresso? - lluvia de ideas
  • 12 Solutions collect form web for “Android requiere el nivel de cumplimiento del compilador 5.0 o 6.0. Se encontró '1.7' en su lugar. Utilice Herramientas de Android> Fijar propiedades del proyecto”

    Ese no es el problema, Jack. El SDK de Android no es x64, pero funciona bien con x64 jvm (y x64 eclipse IDE).

    Como Helios dijo, debe establecer la compatibilidad del proyecto con Java 5.0 o Java 6.0.

    Para ello, 2 opciones:

    1. Haga clic derecho en su proyecto y seleccione "Android Tools -> Fix Project Properties" (si este trabajo din't, prueba segunda opción)
    2. Haga clic con el botón derecho en su proyecto y seleccione "Properties -> Java Compiler" , marque "Habilitar configuración específica del proyecto" y seleccione 1.5 o 1.6 en la casilla "Configuración de cumplimiento del compilador" .
    1. Ir a la carpeta del proyecto y haga clic derecho en él – > properties -> marque la casilla de sólo lectura y haga clic en ok

    2. Haga clic derecho en su proyecto y seleccione "Android Tools -> Fix Project Properties"

    3. Haga clic con el botón derecho en su proyecto y seleccione "Properties -> Java Compiler" , marque "Enable project specific settings" y seleccione 1.5 o 1.6 en la casilla "Configuración de cumplimiento del compilador". (Prueba todos los niveles uno por uno por si acaso)

    4. En Window -> Preferences -> Java -> Compiler , establezca el nivel de cumplimiento del compilador en 1.6 o 1.5.

    Esperemos que resuelva el problema.

    Yo recomendaría el uso de la versión x86 de jvm. Cuando primero conseguí mi nuevo ordenador portátil (x64), quise ir x64 toda la manera (jvm, jdk, jre, eclipse, etc.). Pero una vez que terminé de configurar todo me di cuenta de que el SDK de Android no era x64, por lo que tenía problemas. Vuelve a x86 jvm y deberías estar bien.

    EDIT: 11/14/13

    He visto alguna actividad reciente y pensé que elaboraría un poco más.

    No dije que no funcionaría con x64, solo recomendé usar x86.

    Aquí hay un buen post sobre las ventajas / desventajas de x64 JDK. Beneficios de la plataforma Java de 64 bits

    Proceso del pensamiento: ¿Para qué fin? ¿Por qué estoy intentando usar JDK de 64 bits? ¿Apenas porque tengo un OS 64-bit? ¿Necesito alguna de las características del JDK de 64 bits? ¿Hay alguna característica adicional en el JDK de 64 bits ?! ¿Por qué no esta s *** juega bien juntos !? F *** que voy 32-bit.

    Haciendo Project -> Clean... arregló para mí.

    Mi eclipse había dejado de funcionar así que workspace directorio del área de workspace y después de ejecutar eclipse cuando importo el proyecto tenía este problema. Otras soluciones sugeridas aquí no funcionaron.

    Para la mayoría de las personas que siguen recibiendo el error después de arreglar las propiedades del proyecto, es probable que haya instalado Java 7 SDK al configurar su entorno, pero actualmente no es compatible con el desarrollo de Android.

    Como el mensaje de error dice, debería haber instalado Java 5.0 o 6.0, pero Java 7 fue encontrado.

    Si corrige las propiedades del proyecto sin instalar primero Java 5 o 6, volverá a ver el mismo error.

    • Así que primero, asegúrese de tener Java SDK 5 o 6 instalado, o instalarlo.
    • Compruebe que su variable de entorno (JAVA_HOME) apunta a SDK 5/6.

    Y entonces:

    • Compruebe que Eclipse está usando SDK 5/6 por defecto (Window => Prefs. => Java => Compiler
    • Deshabilitar parámetros específicos del proyecto (Propiedades del proyecto => Compilador de Java)
    • Corregir propiedades del proyecto

    O

    • Deje Eclipse usando JDK 7 de forma predeterminada.
    • Habilitar parámetros específicos del proyecto (Propiedades del proyecto => Compilador de Java)
    • Seleccione Cumplimiento del compilador 1.5 o 1.6 (Propiedades del proyecto => Compilador de Java)

    Estoy de acuerdo con BMSAndroidDroid y Flo-Scheild-Bobby. Yo estaba haciendo un tutorial llamado DailyQuote y había utilizado la biblioteca de Córdoba. Luego cambié mi sistema operativo de Windows a Ubuntu e intenté importar proyectos en Eclipse, (estoy utilizando Eclipse Juno de 64 bits, en Ubuntu 12.04 64-bit , Oracle JDK 7. También instalé las librerías de 32 bits de Ubuntu, así que No hay problemas con 64 y 32 bits), y tiene el mismo problema.

    Como sugiere Flo-Scheild-Bobby, abra la ruta de construcción de configuración y agregue los tarro (s) de nuevo que ha agregado antes. A continuación, quite el vínculo jar antiguo (s) y eso es todo.

    He solucionado este problema empleando los dos procedimientos de:

    1. En Eclipse -> menú 'Proyecto' -> 'Compilador de Java' -> establecer 'Nivel de cumplimiento del compilador' = 1.6 verifique en 'Utilizar configuración de cumplimiento predeterminada' Establecer 'Generated .class compatibility' = 1.6 Set 'Source compatibilty' = 1.6

    2. A continuación, vaya al menú 'Windows' -> 'Preferencias' -> 'Java', expanda 'Java' -> 'Compiler' -> Establecer 'Compiler compliance level' = 1.6

    Sugerencia: La compatibilidad de origen debe ser igual o menor que el nivel de cumplimiento.

    Sugiero que compruebe u para los archivos jar se incluyen correctamente en sus proyectos. Existe la posibilidad de que en ausencia de archivos jar, el proyecto no será compilado

    Como BMSAndroidDroid dicho, este problema puede ser causado por una configuración de ruta de construcción incorrecta.

    Si incluyó algunas bibliotecas en su ruta de compilación, mueva las bibliotecas, la ruta de compilación conservará las referencias incorrectas, no encontrará las bibliotecas durante la compilación y obtendrá un error.

    Para arreglarlo, haga clic derecho en su carpeta de proyecto> construir ruta de acceso> configurar la ruta de construcción A continuación, eche un vistazo a la pestaña de biblioteca, y eliminar las bibliotecas antiguas.

    En mi caso un cambio de openjdk7 a openjdk6 ayudó. Posteriormente cambié el nivel de cumplimiento a 1,6 y todos compilado bien.

    Me encuentro con este problema porque mi debug.keystore ha caducado, por lo que eliminado el debug.keystore en la carpeta .android, y el eclipse se regenerará un nuevo debug.keystore, a continuación, fijo th

    Después de trabajar para mí

     Enable project-specific settings and set the compliance level to 1.6 

    Como puedes hacer eso?

    En el Package Explorer Eclipse, haga clic en su proyecto y seleccione properties . Propiedades La ventana se abrirá. Seleccione Java Compiler en el panel izquierdo de la ventana. Ahora Enable project specific settings y establezca el Complier compliance level en 1.6 . Seleccione Apply y luego OK .

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.