Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Android NDK en el estudio de Android> = 1.4

No considero que esta pregunta sea un duplicado de esta y de estas preguntas ya que son respondidas principalmente por este enlace y que no es adaptable para versiones posteriores de AS.

Puedo encontrar buena información sobre cómo integrar Android NDK con Eclipse , pero que Eclipse y ADT ahora se considera obsoleto por Google.

Al seguir las instrucciones para configurar un proyecto para el plugin gradle experimental, obtengo numerosos errores en el editor de tipo cannot Resolve symbol de todas las adiciones nuevas, así como el error publicado a continuación después de la construcción.

El build.gradle en el proyecto.

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle-experimental:0.2.0' } } allprojects { repositories { jcenter() } } task clean(type: Delete) { delete rootProject.buildDir } 

Y el build.gradle en la aplicación

 apply plugin: 'com.android.model.application' model{ android { compileSdkVersion = 22 buildToolsVersion = "23.0.1" defaultConfig.with { applicationId = "se.einarsundgren.gstreamandroiddemo" minSdkVersion.apiLevel = 22 targetSdkVersion.apiLevel = 22 versionCode = 1 versionName = "1.0" buildConfigFields.with { create() { type = "int" name = "VALUE" value = "1" } } } android.buildTypes { release { minifyEnabled = false proguardFiles += file('proguard-rules.pro') } } android.productFlavors { create("flavor1") { applicationId = 'com.app' } } android.sources{ main { java { source { srcDir 'src' } } } } android.ndk { moduleName = "native" } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.2.0' } 

El error que consigo al limpiar y reconstruir el proyecto:

Error: Se ha producido un problema al configurar el proyecto raíz 'GstreamAndroidDemo'.

No se pudieron resolver todas las dependencias para la configuración ': classpath'. No se pudo resolver com.android.tools.build:gradle-experimental:0.2.0. Requerido por:: GstreamAndroidDemo: unspecified No se pudo resolver com.android.tools.build:gradle-experimental:0.2.0. No se pudo obtener el recurso ' https://jcenter.bintray.com/com/android/tools/build/gradle-experimental/0.2.0/gradle-experimental-0.2.0.pom '. No se pudo obtener ' https://jcenter.bintray.com/com/android/tools/build/gradle-experimental/0.2.0/gradle-experimental-0.2.0.pom '. Par no autenticado

¿Cómo puedo integrar el NDK con un proyecto en Android Studio? Las preguntas previamente vinculadas tienen respuestas válidas para una versión anterior (pre 1.3) y las instrucciones no son adaptables para AS 1.4

2 Solutions collect form web for “Android NDK en el estudio de Android> = 1.4”

Que esta configuración en la que puede apuntar a la ubicación del NDK no está incluida en las versiones posteriores.

Sí, es, al menos en Android Studio 1.4.1 en Linux:

Diálogo de Estructura del Proyecto, Categoría de Ubicación del SDK

¿Cómo puedo integrar el NDK con un proyecto en Android Studio?

Por lo que sé, sigues las instrucciones .


ACTUALIZACIÓN : Con respecto a los problemas gradle-experimental , 0.2.0 y versiones más recientes ciertamente aparecen en jcenter cuando ve su sitio Web . Asegúrese de haber seguido el resto de las instrucciones, como el uso de Gradle 2.5.

Sí lo es. El ajuste está allí en Android Studio 1.5 vista previa 2 en Windows 10 también.

Ubicación de NDK

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.