Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Android Marca roja exclamatoria

Soy muy nuevo en Android. Cada vez que creo un nuevo proyecto utilizando un nuevo espacio de trabajo, obtengo una marca roja exclamatoria en Eclipse en mi proyecto y un error en Appcompat . Busqué aquí una respuesta, pero no contesté lo que estaba buscando, así que solo pregunté esto. Cuando creo un espacio de trabajo en DDMS, se muestra lo siguiente:

 Sending Tracking request failed! 

En Android, después de crear un nuevo proyecto

 WARNING: unable to write jarlist cache file here, src file, layout file not available. 

He buscado mucho y no he encontrado ninguna solución.

5 Solutions collect form web for “Android Marca roja exclamatoria”

OK, lo primero es lo primero. Eclipse ya no es compatible con Google. El único IDE oficial para Android Development es la página de descarga de Android Studio .

Aquí está el anuncio de la terminación del soporte de Eclipse

En los últimos años, nuestro equipo se ha centrado en mejorar la experiencia de desarrollo para la creación de aplicaciones de Android con Android Studio. Desde el lanzamiento de Android Studio, hemos quedado impresionados con la emoción y la retroalimentación positiva. Como Android IDE oficial, Android Studio te ofrece acceso a un conjunto de herramientas potentes y completas para desarrollar tu aplicación en plataformas Android, ya sea por teléfono, muñeca, coche o TV.

Con este fin y para centrar todos nuestros esfuerzos en hacer Android Studio mejor y más rápido, estamos terminando el desarrollo y soporte oficial para las herramientas de desarrollo de Android (ADT) en Eclipse al final del año. Esto incluye específicamente el plugin Eclipse ADT y el sistema de compilación Android Ant.

Tenga en cuenta que el número de personas que utilizan Eclipse para desarrollar aplicaciones de Android está disminuyendo. Usted recibirá cada vez menos apoyo incluso en Stackoverflow con el paso del tiempo. En general, es mejor simplemente hacer el cambio mientras usted está empezando.

Compruebe en el primer enlace, verá una documentación sorprendente en el Android Studio IDE


Si necesita 100% de Eclipse …

Aceptar, por lo que tiene un trabajo que requiere Eclipse o hay alguna otra razón, a continuación, echa un vistazo a esta documentación de Eclipse .

También, aquí está una lista de todos los iconos diferentes que pueden ser exhibidos por Eclipse ( crédito para la lista del icono ).

Los problemas de la trayectoria de la estructura son a veces fáciles de faltar entre otros problemas en un proyecto. Las vistas Explorador de paquetes y Explorador de proyectos muestran ahora un nuevo decorador en proyectos Java y conjuntos de trabajo que contienen errores de ruta de compilación:

Introduzca aquí la descripción de la imagen

Los errores concretos se pueden ver en la vista Problemas y si abre el menú de vista y selecciona Agrupar por> Tipo de problema de Java, todos aparecen en la categoría Camino de estructura:

Introduzca aquí la descripción de la imagen

Por favor, consulte este enlace también aquí

Si va a la carpeta appcompat_v7 / bin, verá que el archivo "jarlist.cache" no aparece o no está sincronizado. Necesita actualizar la carpeta appcompat_v7, sólo presione F5 sobre esa carpeta.

Se agrega la carpeta appcompat_v7 porque utiliza un componente de barra de acción.

Aah. Para evitar una nueva carpeta appcompat_v7_XX al crear un proyecto nuevo, elija una API LEVEL 14 como SDK mínimo requerido. Después debe modificar el archivo AndroidManifest.xml y poner el nivel que necesita.

Cambiarlo android: targetSdkVersion = "19" />

Eliminar todo appcompat_v7_XX. Es un error.

Con appcompat_v7, verá que Eclipse crea dos archivos XML: Activity_main.xml y fragment_main.xml. Si desea tener una opción para crear un proyecto en la forma antigua sólo con activity_main.xml, haga lo siguiente:

Haga una copia de la carpeta "BlanckActivity" ubicada en esta ruta: \ sdk \ tools \ templates \ activities de una versión anterior de ADT.

Cambie el nombre de la carpeta como "BlankActivityNoFragment", a continuación, modifique el nombre de campo del archivo "template.xml" con un bloc de notas como name = "BlankActivityNoFragment"

Copie la nueva carpeta en la misma ruta del nuevo Eclipse IDE: sdk / tools / templates / activities

Ahora verá la nueva plantilla cuando vaya a crear un nuevo proyecto. Recuerde elegir como SDK mínimo requerido una API 14

Si no desea el soporte de la biblioteca appcompat, sólo debe eliminarlo de su proyecto siguiendo los pasos siguientes:

  1. Haga clic derecho en el proyecto
  2. Seleccionar propiedades
  3. En el cuadro de diálogo seleccione Android en el lado izquierdo
  4. En la sección de la biblioteca de verificación de diálogo
  5. Eliminar la biblioteca appcompat seleccionándola y presionar quitar
  6. Extiende tu MainActivity.java con la actividad

Puede ejecutar su proyecto con éxito.

Si desea el apoyo de appcompat, siga estos pasos:

  1. Descargar el último appcompat usando Sdk Manager
  2. Import appcompat proyecto en su eclipse
  3. Agregarlo como un proyecto de biblioteca
  4. Extienda su MainActivity con AppCompatActivity.

Si tienes algún problema con la biblioteca app_compact … Esta es la solución

Espero que funcione ….

Según la documentación

Decora los proyectos Java y los conjuntos de trabajo que contienen errores de ruta de compilación

Puede haber varias razones. La mayoría de las veces puede ser algunas de las siguientes razones,

  1. Ha eliminado algunos de los archivos .jar de su carpeta / lib
  2. Has añadido nuevos archivos .jar
  3. Ha agregado nuevos archivos .jar que pueden estar en conflicto con otros

Así que lo que hay que hacer es resolver los archivos missing / updating / newly_added jar.

  • Haga clic derecho en el proyecto y vaya a propiedades
  • Seleccionar ruta de compilación de Java
  • Vaya a la pestaña Bibliotecas
  • Quite las referencias de los archivos jar que ya ha eliminado. Habrá una marca roja cerca de ellos para que pueda identificarlos fácilmente.
  • Agregue las referencias a los archivos .jar agregados recientemente mediante Agregar JARs Actualizar el proyecto

Esto resolverá el problema si es porque una de las razones anteriores.

Todavía frente a problema? Pruebe esto:

Ir a Windows -> Preferencias -> Android -> Construir y desmarcar "Omitir el embalaje y dexing hasta exportar o lanzar" luego reinicie Eclipse.

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.