Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Advertencia de seguridad en libdvm.so observó al implementar aplicaciones de Android

¿Alguien ha visto esto antes?

ActivityManager: ADVERTENCIA: vinculador: libdvm.so tiene reubicaciones de texto. Esto es perder la memoria y es un riesgo de seguridad. Por favor, arregla.

Esto ocurre cuando intento implementar una aplicación en mi dispositivo. Google no parece ayudar en este momento.

  • Cómo poner un tarro en classpath en Eclipse?
  • Cómo abrir archivos xml de diseño en Android Layout Editor?
  • El emulador de Eclipse se congela
  • El emulador de Android que no muestra la aplicación sólo muestra la piel
  • Eclipse Juno ADT plugin ruta NDK eliminado?
  • Aapt.exe ha dejado de funcionar
  • .execute no se puede resolver a un tipo - AsyncTask (Android)
  • ¿Cómo duplicar un proyecto de ejemplo de SDK en el espacio de trabajo?
  • 5 Solutions collect form web for “Advertencia de seguridad en libdvm.so observó al implementar aplicaciones de Android”

    Si se tratara de su propia biblioteca jni o ejecutable nativo, la solución sería actualizar a ndk r8c o posterior, tal como se discutió en:

    Mylib.so tiene reubicaciones de texto. Esto es perder la memoria y es un riesgo de seguridad. Por favor, arregla

    Para obtener una solución para https://code.google.com/p/android/issues/detail?id=23203

    Sin embargo, como esto parece estar en una biblioteca de plataforma (específicamente la propia VM de Dalvik) en lugar de algo que construyó, no hay mucho de lo que pueda hacer . Es probable que vea esto en cada proceso de actividad (o al menos en tiempo de ejecución), hasta que el fabricante del dispositivo efectúe una actualización.

    Sin embargo, es sólo una advertencia.

    Tuve el mismo error y lo arreglé mediante la eliminación de otras versiones de la aplicación instalada en el dispositivo.

    Estaba recibiendo este error porque estaba tratando de instalar un APK con minSdkVersion conjunto más alto que el dispositivo compatible.

    Puede haber muchas razones detrás de este error, uno de ellos era lo que estaba recibiendo, pero entonces este error fue resuelto.

    Comprobar al crear emulador, es "compatible" o no? En la pantalla de selección del emulador [vea la última columna].

    Si no es compatible, seleccione 'target sdk' como la versión más alta editando 'Emulator' existente [como debería ser mayor que min sdk].

    El mismo error se enfrentó al ejecutar la aplicación en la tableta, la eliminación de la siguiente línea de build.gradle trabajado para mí.

    Eliminar esta línea: testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.